Skip site news

Site news

Picture of FCIT Admin
We are now running Moodle 2.8!
by FCIT Admin - Sunday, 15 February 2015, 4:26 pm
 

Courses from our previous Moodle 2.2 installation have not been upgraded. If you still need access to those courses, please visit moodle.fcit.usf.edu/moodle/.